TP-Link Archer C7 v2 OpenWRT VLAN UniFi HyppTV

  • Last updated on December 27, 2016
  • Network

There are many tutorials available on Internet on how to setup VLAN on OpenWRT Chaos Calmer 15.05 but finding one specifically for Archer C7 v2 with the right VLAN settings for Malaysia’s UniFi HyppTV was a little challenging. In the process of trial and error, I had to recover my router from failsafe mode so please be careful.

VLAN switch settings

Disclaimer: I cannot be held responsible for anything that goes wrong to your router. Proceed at your own risk!

Screenshot of my Switch settings:

UniFi HyppTV VLAN Switch

Physical LAN ports 1, 2, 3 are not VLAN tagged while port 4 is for HyppTV IPTV.

Note: Physical LAN port number is not the same as port numbers on OpenWRT switch settings! For example, physical port 4 is actually port 5 on OpenWRT switch settings.

Excerpt copied from /overlay/upper/etc/config/network:

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'
option mirror_source_port '0'
option mirror_monitor_port '0'

config switch_vlan
option device 'switch0'
option vlan '1'
option vid '1'
option ports '0 2 3 4'

config switch_vlan
option device 'switch0'
option vlan '2'
option vid '2'
option ports '1 6'

config switch_vlan
option device 'switch0'
option vlan '3'
option vid '500'
option ports '1t 6t'

config switch_vlan
option device 'switch0'
option vlan '4'
option ports '1t 5'
option vid '600'

IPTV network interface

Navigate to Interfaces > Add New Interface, enter the following:

UniFi HyppTV VLAN Interface

Excerpt copied from /overlay/upper/etc/config/network:

config interface 'iptv'
option proto 'none'
option ifname 'eth0.600'
option auto '1'

You may now enjoy watching HyppTV :)